Free Product Editions


All of our products require the Windows operating system with version 3.5 or higher of the .NET Framework.   If you use Windows XP or Windows Vista then you may have to download version 3.5 or higher of the .NET Framework from Microsoft’s web site.   If you use Windows 7, Windows 8, or Windows 8.1, then you will already have an appropriate version of the .NET Framework installed.

Order the standard edition of any of our products on our order page.

"VB" refers to the .NET implementation of Visual Basic, previously known as "VB.NET" (not VB6).

We appreciate feedback on our products.  Send your comments, feature requests, or descriptions of any problems that you encountered to us at: support@tangiblesoftwaresolutions.com